All
Technology
SEO
Design
Programming
iPhone
Android

Why is my site STILL not in the Google index?

    Share on Facebook Create Topic
by AmorA
by BookWorm15
Hello everyone - new forum member and first post. I apologize for starting this thread but I cannot find a clear answer from using the search.

I have a new retail site that went live on 4/27 of this year. This site is still not in the google index, even though I have created a detailed sitemap, submitted the URL, and have around 3400 links back to my site from various other sites, most from a California gun forum I frequent. What I also find confusing, is that I have another site that is not even live yet, that uses the same shopping cart system (Aspdotnetstorefront), was set up just a few weeks ago, yet this site is in the index - what gives? Could my riflegear site be banned or something - how do I find out?

Just to clarify, a search of "site:domain" with my domain gives zero results. My site and sitemap have been verified by Google and my site is crawled on a regular basis - but 3 months later and still not in the index

Thanks for any help.
by Modestgirly
Quote:
Originally Posted by Noj
Maybe Google thinks shooting people may be bad !

Seriously could be a lot of reasons, but im not going to help sell any gun to anyone so hope you find someone with different morals to me.


I certainly don't condone or encourage the shooting of anyone either but what does that have to do with selling a legal product on the internet? I know that Google does not allow certain firearms components for sale in adwords, but they do not prohibit firearms related sites from being in the index. Seriously, I can respect your morals but I am not selling firearms, just accessories. My question is about SEO and what may be affecting my inclusion in the index - if you don't have anything to offer then please just ignore my thread - I am not posting this to ask about your opinions on the 2nd amendment, target shooting, or the right to self-defense - just a question about google SEO.
by Cornishgal
Could you provide URL for review?
by Dshipper
Quote:
Originally Posted by flat4
Could you provide URL for review?

I think it's www . riflegear . com
Don't you have something blocking in the robots.txt file?
by Mairin
Maybe Google thinks shooting people may be bad !

Seriously could be a lot of reasons, but im not going to help sell any gun to anyone so hope you find someone with different morals to me.

Quote:
Originally Posted by RifleGear
Hello everyone - new forum member and first post. I apologize for starting this thread but I cannot find a clear answer from using the search.

I have a new retail site that went live on 4/27 of this year. This site is still not in the google index, even though I have created a detailed sitemap, submitted the URL, and have around 3400 links back to my site from various other sites, most from a California gun forum I frequent. What I also find confusing, is that I have another site that is not even live yet, that uses the same shopping cart system (Aspdotnetstorefront), was set up just a few weeks ago, yet this site is in the index - what gives? Could my riflegear site be banned or something - how do I find out?

Just to clarify, a search of "site:domain" with my domain gives zero results. My site and sitemap have been verified by Google and my site is crawled on a regular basis - but 3 months later and still not in the index

Thanks for any help.
by Nadinerosado
Quote:
Originally Posted by flat4
Could you provide URL for review?


Ny noobness prevents me from posting the url, but yes it is www dot riflegear dot com
by Reader
Quote:
Originally Posted by ted7
I think it's www . riflegear . com
Don't you have something blocking in the robots.txt file?


the robots.txt file is supplied by the shopping cart and blocks from certain directories, such as the checkout page, bin dir, etc... I don't think this is it because the exact same robots.txt file is on my other site which is included in the index already.

I did have a thought though, what does Google consider "keyword loading"? I had about a dozen search keywords, such as "cases", "ar-15", "stocks", etc... that were set on every product page - could this be the issue? I just re-ran a query that resets all those keywords to not include those generic terms on every page - perhaps that is the issue. Any other ideas or comments?
by readingaddict
Nice job flat4!

That is definitely the issue!
by Peterfishboy
Yeah this is really weird..
You have an domain name from Feb of this year..
I checked a few of your inbound links and those pages are all indexed...

Robots.txt doesn't look like it is restricting anything wrong

I noticed you are the only one serving a page of the ip address.. has that ip address ever been banned? Or has the site been banned in the past?

A lot of your Inbound links look questionable, but not that bad IMO..

I would maybe go down the file for re-inclusion request and see what Google says.


Sorry hope it helps,
-Flat4
by Ragin_cajuns
And your not cloaking or anything like that?

one thing I would check is your redirect from www to non-www

What I find really odd is yahoo and msn don't have any content index in any SE for http://www.riflegear.com
by Seasons_Of_Bliss
I'm not aware of being banned, do they send you an email or any kind of notice? What is weird is that before I went live I had a simple "index.html" page that said "coming soon..." and at that point I was in the index, shortly after going live and replacing the index.html with the default.aspx page, I noticed I was no longer in the index and have not been in it since. Google does not make this easy - is there any way to get anyone from Google to take a look at it and give me an idea what the issue is?


Quote:
Originally Posted by flat4
Yeah this is really weird..
You have an domain name from Feb of this year..
I checked a few of your inbound links and those pages are all indexed...

Robots.txt doesn't look like it is restricting anything wrong

I noticed you are the only one serving a page of the ip address.. has that ip address ever been banned? Or has the site been banned in the past?

A lot of your Inbound links look questionable, but not that bad IMO..

I would maybe go down the file for re-inclusion request and see what Google says.


Sorry hope it helps,
-Flat4
by gloriana
Quote:
Originally Posted by flat4
Duh. can't believe I didn't just look at the code of the site...lol...

Look in your code for this meta tag ->
<meta name="robots" content="noindex,nofollow,noarchive"> remove that

That is prob your problem

Hope it helps,
-Flat4

Sh*t I missed that though I was looking to it

grrrr!!!!
by YellowButterfly85
I'm pretty new to this so please bear with me. What do you mean about redirect from www to non-www?

As far as "cloaking" - I am not aware of doing anything in this area, other than when I said I had about a dozen keywords stuffed into every product page. From reading the guidelines it seems this is a no-no so I just removed them and now it pretty much just has the product name, sku, mfg name, etc... as keywords for each product page.

Quote:
Originally Posted by flat4
And your not cloaking or anything like that?

one thing I would check is your redirect from www to non-www

What I find really odd is yahoo and msn don't have any content index in any SE for http://www.riflegear.com
by Zenchanlol
Duh. can't believe I didn't just look at the code of the site...lol...

Look in your code for this meta tag ->
<meta name="robots" content="noindex,nofollow,noarchive"> remove that

That is prob your problem

Hope it helps,
-Flat4
by bryant
Flat4, I think you found the issue! Searching the forum for my shopping cart system it appears that this tag should only be used for customers that are not using the default locale currency - something to do with avoiding getting indexed in multiple languages. Well, anyway, it appears that this is a bug in the version I am using and an upgrade will fix it. Thanks for finding this as it appears I am on my way to getting this resolved now!


Quote:
Originally Posted by flat4
Duh. can't believe I didn't just look at the code of the site...lol...

Look in your code for this meta tag ->
<meta name="robots" content="noindex,nofollow,noarchive"> remove that

That is prob your problem

Hope it helps,
-Flat4
Home | Contact | Privacy Policy |